APS - Error #1012 - Problem with upgrading PTT Pod NNTN8191 using APS 4.6.0


Error

Upgrade of PTT Pod NNTN8191 fails in APS 4.6.0 software. Error #1012 appears: "The device failed to upgrade!!! Please disconnect and reconnect the USB cable for this device and try again."

The device after disconnecting from the PC does not continue to work on the old software. The device is corrupted and it is not possible to get any information about the device in the APS. After turning the Pod only repeated beeps can be heard and the LED blinks orange.

Root Cause

The error code #1012 returned in the APS software is about the CSR portion of the PTT Pod failing to upgrade.

This happens because the APS 4.6.0 has an unsigned CSR driver. Hence, the CSR driver couldn't be installed and APS fails the upgrade.

Workaround/Fix

The APS software needs to be updated to the latest versions 4.7.0 or 4.8.0 and then the PTT Pod upgrade can be performed and the CSR driver can be installed. 
Once the PTT Pod has been updated with the latest versions of APS, they work correctly. 
 
 
APS 4.8.0 and the PTT Pod firmware version can be found on the MSI website:
APS_4.8.0: https://www.motorolasolutions.com/content/dam/msi/docs/products/software/aps_4.8.0.zip
OCW_WPOD_R01.03.10: https://www.motorolasolutions.com/content/dam/msi/docs/products/software/OCW_POD_R01.03.10_Firmware_Upgrade_Package.zip